Latest version of Chrome browser causes issues with choice dropdown controls
Incident Report for CMX1 Platform
Resolved
We have deployed a fix for the dropdown control issue.
Posted Nov 14, 2024 - 18:39 PST
Identified
We have developed a fix for the dropdown issue and are in the process of testing it. We plan on deploying it at 6 PM Pacific time.
Posted Nov 14, 2024 - 16:55 PST
Investigating
The latest Chrome browser -- Version 131.0.6778.70 (Official Build) (64-bit) has a change that affects our Choice DropDown Lookup controls. This makes navigating to certain parts of client sites impossible.

We recommend NOT updating to this version of Chrome yet if you are able. If you have already updated, you can work around this by using an alternative browser such as Firefox or Edge.

We are working on a fix and will apply it as soon as possible.
Posted Nov 13, 2024 - 17:59 PST
This incident affected: Activity Studio Product Family and Supply Chain Product Family.